分类 Ruby 下的文章

宇托 PostgreSQL, Ruby, Rails 0 条

之前想学习Rails on Ruby,在安装PostgreSQL的Ruby库(sh#gem install pg)时,总是出现下面的错误。Can't find the 'libpq-fe.h header在网上找到半天,各种答案都有,我也试了N种方法,发现都不行。最后在StackOverflow里找到了答案。其解决方法是安装PostgreSQL的开发包。安装命令如下:sudo apt-get install libpq-dev之后...

宇托 Install, Ubuntu, Rails 0 条

我的Ubuntu的版本是14.04,其它的版本可能在安装上有些不同。在安装Rails之前,必须先安装好Ruby。安装方法在下面的地址有介绍。Ubuntu下RVM的安装和使用Rails安装步骤要安装PostgreSQL,最好先更新一下系统。命令如下:sh#sudo apt-get updateRails要用到Javascript,所以最好安装一下NodeJS。命令如下:sh#sudo apt-get install nodejs安装...

宇托 Install, Ubuntu, Ruby 0 条

我的Ubuntu的版本是14.04,其它的版本可能在安装上有些不同。安装步骤如下要安装RVM,最好先更新一下系统。命令如下:sh#sudo apt-get update为了安装RVM,我们必须要安装CURL。安装命令如下:sh#sudo apt-get install curl然后我们就可以安装RVM了。安装命令如下:sh#\curl -L https://get.rvm.io | bash -s stable我的在这一步出问题了...