最新消息:历时半年,永住昨天下来了

安装PostgreSQL时出现VC++ runtime error的解决方法

最近想玩玩PostgreSQL,下载了一个9.3.2-1的64位版本,文件名为:postgresql-9.3.2-1-windows-x64.exe。安装时却发现有以下问题,根本安装不了。如下图:

在网上找了找,问题原因可能是VC++ runtime 已经安装,所以我们在安装PostgreSQL时不安装VC++ runtime 即可。方法如下:在postgresql-9.3.2-1-windows-x64.exe文件的同级目录下新建一个bat文件,文件名可以自取,比如postgresql-9.3.2-1-windows-x64.bat,内容如下:

postgresql-9.3.2-1-windows-x64.exe --install_runtimes 0

然后执行新建的bat文件即可。


参考地址:http://mtoou.info/postgresql-anzhuang/

转载请注明:宇托的狗窝 » 安装PostgreSQL时出现VC++ runtime error的解决方法

发表我的评论
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址