最新消息:把Logo换了一下,虽然丑了点,但至少完全是自己的设计

Yii2安装依赖包出错的解决方法

PHP 宇托 849浏览 暂无评论

最近在安装Yii2依赖包时,总是出现下面的错误。

Your requirements could not be resolved to an installable set of packages.

Problem 1
- yiisoft/yii2 2.0.3 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
- yiisoft/yii2 2.0.3 requires bower-asset/jquery 2.1.*@stable | 1.11.*@stable -> no matching package found.
- Installation request for yiisoft/yii2 == 2.0.3.0 -> satisfiable by yiisoft/yii2[2.0.3].

原因是Composer有问题。

解决方法是安装composer-asset-plugin。其命令如下:

Bash
php composer.phar global require "fxp/composer-asset-plugin:1.0.0"

参考地址:Yii2 Composer is broken!

转载请注明:宇托的狗窝 » Yii2安装依赖包出错的解决方法

发表我的评论
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址